Upgrading DocuNECT

Documentation
Article Library

Date: 09/16/2014
Applies to Version: v4.5, v4.6, v4.7 and v4.8

This article provides a guide to upgrade your DocuNECT system.

Is Your Version Still Supported?

Typically our upgrade scripts are design to migrate between different versions of DocuNECT, but we recommend making sure your DocuNECT system is currently within the supported version list. If not, then call our support for guidance on whether the standard upgrade supports the version you are on. Alternatively the Downloads page contains a list of currently supported versions.

Backup the Database

Most DocuNECT upgrades make database changes so it is strongly recommended to backup the database before performing the upgrade.

Upgrade Preparation

The first stage of the upgrade is to uninstall all existing DocuNECT components. Once all existing components are uninstalled then review the pre-requisites for the current version to make sure non of the supporting components also need to be upgraded.

Upgrade Database and Server in v4.5 and v4.6

Start by upgrading the DocuNECT Server component and then adding the DocuNECT Lifecycle Server component. On the web server install the DocuNECT Web component and during the database wizard it will prompt you to either create a new database or upgrade an existing one. Select the upgrade option, select your existing database and continue. The upgrade script will upgrade the database. If an error occurs during this upgrade process then use the Copy to Clipboard button to copy the error and email it our support.

Upgrade Database and Server in v4.7 and v4.8

Start by upgrading the DocuNECT Server component and then adding the DocuNECT Lifecycle Server component. Use the Database Manager application to select and upgrade the database. The upgrade script will upgrade the database. If an error occurs during this upgrade process then use the Copy to Clipboard button to copy the error and email it our support. On the web server install the DocuNECT Web component and connect to the newly upgraded database when prompted.

Station Licensing

After the database has upgraded, login into the system as the cmsadmin account and confirm the station is still registered. Depending on what version you are upgrading from you may need to obtain a station license. Email our support with the station code to do this. Also, the station may need to be repaired.

Registering and Licensing the Station

Connector Upgrades

Once you have confirmed that the upgraded station is active, then click on the Connectors tab and click on each connector and press the Upgrade button and re-import the newer versions of the connectors which you can download from the ContentConnector Library. Note, if you have installed any of the system connectors then you will have to delete the connector and re-import them. If you have custom connectors then contact Portford support for guidance.

Upgrading Customizations

If you have used the DocuNECT SDK to create custom connectors or integrations then you will need to add the PSG.CMS.dll and PSG.CMS.DAL.SqlServer.dll for the new version back into your Visual Studio Project and recompile. You will also need to review the SDK documentation to make sure that no SDK commands have been deprecated.